Firefox 3 beta 4が動いた

Firefox 3 beta 4からGTK+ 2.10以上を要求するようになった。

ところが、etchのGTK+は2.8.2なのでbeta 3までしか動かずに困っていた。なにしろ、beta 3だと印刷しようとするとFirefox 3がクラッシュするので(私の環境だけかもしれないけど)。

いろいろ調べてたら、etch向けのGTK+ 2.10のプライベート版を公開しているサイトがあった。

Repository für Debian

ここにあるように、etchのbackport用として、sources.listに

deb http://debian.geole.info/ etch-backports main contrib non-free

と書いてやればGTK+2.10がインストールされる。署名の問題でapt-get updateが文句を吐くのが気持ち悪いが、取り敢えず強行インストールしてみたのがちと不安。

これで、無事、Firefox 3 beta 4が動くようになった。印刷してもクラッシュしないぞ(笑)。でも、起動時にwarningがたくさん出るのが気になる、、、

ちなみに、ネタの大元(etch用のGTK+ 2.10)の話はこちら。

http://forums.debian.net/viewtopic.php?p=137830&sid=d6edc15ca16f1649d53e4f7e120ee416

ここの人は、GTK+を上げてもFirefox 3 beta 4が動かないようなことを書いているが、、、

Debian/etch, Linux

Posted by k1